[ cegcc-Bugs-2958451 ] I tried compile sed, wget , gawk

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view

[ cegcc-Bugs-2958451 ] I tried compile sed, wget , gawk

Bugs item #2958451, was opened at 2010-02-25 02:19
Message generated for change (Comment added) made by dannybackx
You can respond by visiting:

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: CeGCC (arm-wince-cegcc)
Group: None
Status: Open
Resolution: None
Priority: 5
Private: No
Submitted By: Nobody/Anonymous (nobody)
Assigned to: Nobody/Anonymous (nobody)
Summary: I tried compile sed, wget , gawk

Initial Comment:
I use Ubuntu 9.04 and cegcc-0.59.1.tar.bz2 .

I tried compile sed-4.2.1.tar.bz2 but error.
 -Wall -mms-bitfields -MT utils.o -MD -MP -MF .deps/utils.Tpo -c -o utils.o utils.c
utils.c: In function 'follow_symlink':
utils.c:363: error: 'S_IFLNK' undeclared (first use in this function)
utils.c:363: error: (Each undeclared identifier is reported only once
utils.c:363: error: for each function it appears in.)
utils.c:371: warning: implicit declaration of function 'readlink'


#ifdef __CYGWIN__
#include <cygwin/stat.h>
#define stat64 __stat64
struct stat
  dev_t st_dev;
  ino_t st_ino;
  mode_t st_mode;
  nlink_t st_nlink;
  uid_t st_uid;
  gid_t st_gid;
  dev_t st_rdev;
  off_t st_size;
  /* SysV/sco doesn't have the rest... But Solaris, eabi does.  */
#if defined(__svr4__) && !defined(__PPC__) && !defined(__sun__)
  time_t st_atime;
  time_t st_mtime;
  time_t st_ctime;
  time_t st_atime;
  long st_spare1;
  time_t st_mtime;
  long st_spare2;
  time_t st_ctime;
  long st_spare3;
  long st_blksize;
  long st_blocks;
  long st_spare4[2];

#define _IFMT 0170000 /* type of file */
#define _IFDIR 0040000 /* directory */
#define _IFCHR 0020000 /* character special */
#define _IFBLK 0060000 /* block special */
#define _IFREG 0100000 /* regular */
#define _IFLNK 0120000 /* symbolic link */
#define _IFSOCK 0140000 /* socket */
#define _IFIFO 0010000 /* fifo */

#define S_BLKSIZE  1024 /* size of a block */

#define S_ISUID 0004000 /* set user id on execution */
#define S_ISGID 0002000 /* set group id on execution */
#define S_ISVTX 0001000 /* save swapped text even after use */
#define S_IREAD 0000400 /* read permission, owner */
#define S_IWRITE 0000200 /* write permission, owner */
#define S_IEXEC 0000100 /* execute/search permission, owner */
#define S_ENFMT 0002000 /* enforcement-mode locking */

#define S_IFMT _IFMT
#define S_IFDIR _IFDIR
#define S_IFCHR _IFCHR
#define S_IFBLK _IFBLK
#define S_IFREG _IFREG
#define S_IFLNK _IFLNK
#define S_IFIFO _IFIFO
#endif /* !_POSIX_SOURCE */

#ifdef _WIN32
/* The Windows header files define _S_ forms of these, so we do too
   for easier portability.  */
#define _S_IFMT _IFMT
#define _S_IFDIR _IFDIR
#define _S_IFCHR _IFCHR
#define _S_IFIFO _IFIFO
#define _S_IFREG _IFREG
#define _S_IREAD 0000400
#define _S_IWRITE 0000200
#define _S_IEXEC 0000100

#define S_IRUSR 0000400 /* read permission, owner */
#define S_IWUSR 0000200 /* write permission, owner */
#define S_IXUSR 0000100/* execute/search permission, owner */
#define S_IRGRP 0000040 /* read permission, group */
#define S_IWGRP 0000020 /* write permission, grougroup */
#define S_IXGRP 0000010/* execute/search permission, group */
#define S_IROTH 0000004 /* read permission, other */
#define S_IWOTH 0000002 /* write permission, other */
#define S_IXOTH 0000001/* execute/search permission, other */

#define S_ISBLK(m) (((m)&_IFMT) == _IFBLK)
#define S_ISCHR(m) (((m)&_IFMT) == _IFCHR)
#define S_ISDIR(m) (((m)&_IFMT) == _IFDIR)
#define S_ISFIFO(m) (((m)&_IFMT) == _IFIFO)
#define S_ISREG(m) (((m)&_IFMT) == _IFREG)
#define S_ISLNK(m) (((m)&_IFMT) == _IFLNK)
#define S_ISSOCK(m) (((m)&_IFMT) == _IFSOCK)

int _EXFUN(chmod,( const char *__path, mode_t __mode ));
int     _EXFUN(fchmod,(int __fd, mode_t __mode));
int _EXFUN(fstat,( int __fd, struct stat *__sbuf ));
int _EXFUN(mkdir,( const char *_path, mode_t __mode ));
int _EXFUN(mkfifo,( const char *__path, mode_t __mode ));
int _EXFUN(stat,( const char *__path, struct stat *__sbuf ));
mode_t _EXFUN(umask,( mode_t __mask ));

#if defined(__rtems__) || defined(__CYGWIN__) && !defined(__INSIDE_CYGWIN__)
int _EXFUN(lstat,( const char *__path, struct stat *__buf ));
int _EXFUN(mknod,( const char *__path, mode_t __mode, dev_t __dev ));


I'm not use Cygwin.

I tried compile wget-1.12 , but error
arm-cegcc-gcc -DHAVE_CONFIG_H -I. -I../src   -D_WIN32_WCE=0x0400  -O3 -Wall -mms-bitfields -MT strcasestr.o -MD -MP -MF .deps/strcasestr.Tpo -c -o strcasestr.o strcasestr.c
In file included from strcasestr.c:27:
./strings.h:27:26: error: strings.h: No such file or directory
make[3]: *** [strcasestr.o] Error 1

I tried compile gawk-3.1.7 , but error.
arm-cegcc-gcc -DDEFPATH="\".:/usr/local/wince/share/awk\"" -DHAVE_CONFIG_H -DGAWK -DLOCALEDIR="\"/usr/local/wince/share/locale\"" -I.  -I./libsigsegv/src -D_WIN32_WCE=0x0400 -D_WIN32_IE=0x0400 -DNO_ERRNO_H  -O3 -Wall -mms-bitfields -MT replace.o -MD -MP -MF .deps/replace.Tpo -c -o replace.o replace.c
In file included from replace.c:47:
missing_d/system.c:19: error: expected declaration specifiers or '...' before string constant
missing_d/system.c:19: error: expected declaration specifiers or '...' before numeric constant
missing_d/system.c:19: error: conflicting types for 'r_fatal'
missing_d/system.c:19: note: a parameter list with an ellipsis can't match an empty parameter name list declaration
awk.h:1162: note: previous declaration of 'r_fatal' was here
missing_d/system.c: In function 'system':
missing_d/system.c:24: error: argument 's' doesn't match prototype
/opt/cegcc/lib/gcc/arm-cegcc/4.4.0/../../../../arm-cegcc/include/stdlib.h:122: error: prototype declaration
make[2]: *** [replace.o]




>Comment By: Danny Backx (dannybackx)
Date: 2010-02-25 17:35

What is your point ?

I created a small test :
#include <sys/stat.h>

int x()
        return S_IFLNK;

arm-cegcc-gcc -c test.c compiles this without problem.

So I guess you may be using something different ?

Also, I am not sure why you expect a source not written for CE to compile
with cegcc without a problem.


You can respond by visiting:

Download Intel&#174; Parallel Studio Eval
Try the new software tools for yourself. Speed compiling, find bugs
proactively, and fine-tune applications for parallel performance.
See why Intel Parallel Studio got high marks during beta.
Cegcc-devel mailing list
[hidden email]